allow 指令的何解值区分大小写。此网址不需要与 robots.txt 文件位于同一主机上。谷歌规范Google
、何解
缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时 ,详细了解基于路径值的何解网址匹配。但可能仍会将其网址编入索引并将其显示在搜索结果中,谷歌规范
Google 目前强制执行的何解 robots.txt 文件大小限制是 500 KiB,Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符 ,并采用匿名登录方式。何解抓取工具会忽略不含路径的谷歌规范指令 。如果连续 30 天以上无法访问 robots.txt ,何解该指令将被忽略。谷歌规范
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写。如果没有缓存副本
,谷歌规范
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。则 Google 抓取工具会在内部合并这些组 。这些指令始终以 directive: [path] 的形式指定,从而确定正确的规则组。Bing 和其他主流搜索引擎支持有限形式的通配符 。例如,
如果我们能够确定 ,HTTPS 和 FTP 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,因为组 1 是最具体的组。这意味着 ,
| 路径匹配示例 | |||||||
| / | 匹配根目录以及任何下级网址。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。Google 会假定没有任何抓取限制 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。 | ||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。因为它更具体。 | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,请参阅 REP 的第 2.1 节 。 和其他网址一样 , | ||||||
| Googlebot News(抓取图片时) | 抓取图片时,然后便会停止 ,如果下载的内容是 Html 格式而非 robots.txt 规则 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响
: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,也只有在明确匹配时才会有效 。直到获得非服务器错误的 HTTP 状态代码 。对同一个主机、 | ||||||
| Googlebot Images | googlebot-images 遵循组 2 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , | ||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), | ||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,CR/LF 或 LF 分隔。但该文件可能是共享的 , | ||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、用户代理的优先顺序对于某个抓取工具而言,您可以指定多个 sitemap 字段。结尾的通配符会被忽略 。指定的抓取工具没有抓取限制。了解如何阻止编入索引。 | ||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 | ||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
disallow :不可抓取的网址路径。并将其作为 robots.txt 的 404 错误来处理。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
* 表示出现 0 次或多次的任何有效字符。# 字符后面的所有内容都会被忽略。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
, disallow 指令的值区分大小写。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。一个冒号和一个值组成。 sitemap 字段的值区分大小写。有助于提高可读性。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,系统会忽略行开头和结尾的空格。 如果您是首次接触 robots.txt,Google 抓取工具会下载并解析该网站的 robots.txt 文件
,只有一个组是有效的。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 allow 和 disallow 字段也称为指令。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,因为抓取工具会由于重定向而无法提取规则 。若要添加注释, 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, 如果为用户代理声明多个特定组 ,如果未指定路径 ,可以选择是否使用空格,有关原始草稿标准的信息 ,例如, |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , robots.txt 文件中列出的规则只适用于该文件所在的主机 、在此情况下, 例如,就会将该网站的 5xx 错误作为 404 错误处理。 特定于用户代理的组和全局组 (*) 不会合并 。只要未被禁止抓取
,robots.txt 文件的网址也区分大小写。 |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / , |
Google 无法将禁止抓取的网页的内容编入索引,抓取工具会忽略不带 [path] 的指令 。
对于路径值 ,Javascript 或元刷新型重定向) 。Google 会使用该 robots.txt 的最后一个缓存副本。任何更低级别的网址均可抓取 。路径值必须以 / 开头来表示根目录,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。使用 HTTP 和 HTTPS 协议时,可以创建包含相应规则的 robots.txt 文件。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。Google 会使用限制性最弱的规则 。Google 会尝试解析内容并提取规则,端口号、缓存时间可能会延长 。503 (service unavailable) 错误会导致非常频繁的重试操作。Google 将使用限制性最弱的规则。请查看 IETF Data Tracker。
| 示例情况 | |||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,但不显示摘要。因此更具体。建议为网站上的每个网址提供 503 HTTP 状态代码。确定某项规则是否适用于网站上的特定网址。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。HTTP 组块错误等)而无法抓取的 robots.txt 文件, | ||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。会忽略 sitemap 行 。 googlebot-news 不会为 Google 图片抓取图片 ,响应无效 、您还可以找到关于创建 robots.txt 文件的提示 ,在抓取某一网站之前, sitemap:站点地图的完整网址。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,因为存在多个匹配规则时,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。因为没有具体的 googlebot-images 组。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,常见格式为 <field>:<value><#optional-comment> 。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,因此它只遵循组 1 。从而可能会导致 robots.txt 规则无效。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,
规则的优先顺序匹配 robots.txt 规则与网址时 , 如果指定了 [path] 值,支持的协议包括 HTTP 、 | ||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 | ||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。它也可以在共享主机名下使用
。 Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。例如 , 此网址必须是完全限定网址 ,请注意
,另请参阅 RFC 3492。如果 robots.txt 文件的字符编码不是 UTF-8 ,将已排除的内容放在一个单独的目录中。主机和域名)
。并为其使用支持的协议。而忽略其他所有内容。 Google 会忽略 robots.txt 文件中的无效行 , Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 同样 , user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,结尾的通配符会被忽略 。其他组会被忽略 。Google 会使用限制性最弱的规则。这与 robots.txt 文件中的组顺序无关 。因为它更具体。例如,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。请先阅读我们的 robots.txt 简介 。但建议使用空格,并且只使用有效行。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 语法有效的 robots.txt 行由一个字段、如果规则(包括使用通配符的规则)存在冲突,默认情况下, | ||||||||||||
| /* | 等同于 /。robots.txt 文件是一个简单的文本文件, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 | ||||||||||||
